Notification emails are delayed
Minor incident
Salto KS Web Application
2025-12-18 16:30 UTC
· 2 hours, 40 minutes
Updates
Resolved
December 18, 2025 · 19:09 UTC
We scaled up our services to help process the load and now we see emails are being sent instantly again.
We are now marking this incident resolved.
Issue
December 18, 2025 · 18:08 UTC
Currently we are experiencing delays with our email service provider.
Emails are taking over 1 hour to be processed but are being processed slowly. This affects all email related notifications such as, user sign up notifications and any configured notifications in-app.
We are in touch with our provider and are hope to resolve this soon.
← Back
STATUS